July 2014 » Mcbeev.com Upgraded to Kentico 8
Jul 22

Mcbeev.com Upgraded to Kentico 8

Introduction

I finally had enough time to sit down and upgrade my blog here at Mcbeev.com to Kentico 8. All and all it was not that bad of a process. I'm pretty happy with the results because the improvements in the product are quite worth it. The only challenging part was upgrading all of the custom code and developer examples that I have written over the years. It has been a fun trip down memory lane for some of them. 

 

Upgrade Tips

Like I mentioned in the introduction, the upgrade process was not that bad. However, I did run into a few things that initally tripped me up. I thought I would create a quick list of gotchas here in this blog post to let share some of the knowledge. Hopefully this list saves you some time and heartburn if you are working on upgrading a site to Kentico 8.

 

  • During the file portion of the upgrade_7_0_8_0 executable, not all dll files in \bin were updated correctly.
    • Apparently when I downloaded the backup zip of my blog to my Windows 7 machine at home the download file was "blocked". After extracting the site that blocked flag was still on all of the dll files. So the installer was not able to remove / modify them. I ended up with a mix of 7.0 and 8.0 dll files in my solution. Not Good. After unblocking the zip file everything went fine.
    • Also make sure you close Visual Studio before running the upgrade package. You don't need to have the site running at the time of upgrade.

 

  • During the SQL portion of the upgrade_7_0_8_0 executable, the upgrade_8_0 SQL Script timed out.
    • As it turns out the ConnectionTimeout variable is used from your web.config file and mine was fairly low. I had to manually run the SQL Script in SQL Management Studio to avoid this timeout. I did perform a database restore after the initial run of the script errored.

 

  • Make sure the Import Package runs on the first time run of your newly upgraded Kentico 8 site.
    • This package should run automatically if everything runs perfectly. But in my case it did not.
    • If you see a bunch of broken images, or widgets / reports missing this is most likely the case. You can simply Import the Upgrade_70_80.zip package from Admin -> Sites -> Import site or objects to correct this.

 

  • Don't run "vanilla" Kentico 8.0.
    • As expected, there were a few issues with first release. Nothing crazy, but I still recommend hotfixing to a newer release. 

 

 

  • Update Custom Classes.
    • If you register custom classess for custom objects such as Scheduled Tasks, Workflow Actions, and/or Integration Connectors update the way you register these classes. The method has changed in Kentico 8.

 

  • Double check your UI Personalization.
    • Basically the upgrade resets all of your items to the Custom module that now comes built in to 8. 
    • This is true even if you have added Tabs to Pages application or Tools to the old CMSDesk. I had a few UI Elements that I had to correct the Parent Element on before they showed up correctly in the new navigation system that Kentico 8 has.

 

 

I hope this list helps if you run into any issues with upgrading your site from Kentico 7 to Kentico 8. Do you have any common issues you  have seen during the upgrade process ? If so I would love to hear from you in the comments on this post.

 

You might also be interested in

[X]

Be the first to know about my latest Kentico Tips & Tricks!

Do not show again