July 2014 » Yammer Web Part Pack Update for Kentico
Jul 14

Yammer Web Part Pack Update for Kentico

Introduction

A few people have recently asked if my web parts for integrating with Yammer work with version 8.0 of Kentico. As it turns out, not only has Kentico released a new major version since I wrote these web parts, but so has the Yammer API. Tonight I retro-fitted the code to work with the new API as well as both versions 7.0 and 8.0 of Kentico.

 

Change Notes

Like I mentioned in the introduction, the biggest change to account for was the fact that Yammer changed their Yammer Embed developer options. 

  • You no longer need to specify a Data App ID, the property has been removed.
  • The Javascript Yammer Embed URL has changed, the code now correctly uses the updated URL
  • I made a slight performance enhancement to load all script as a Startup Script (bottom of the body)
  • The Yammer Group Feed web part now requires a Width (at least 400px) and a Height, based on Yammer's new requirement.
  • New version of the code that works in Kentico 8.0.0+. By the way, if you are still using version 8.0 vanilla go hotfix right now!

 

Download

 

Installation Instructions

The installation instructions for the Yammer Web Part Pack 1.1 are the same as the original version. You can find out how to install the web parts by reading my original post, Yammer Web Part Pack for Kentico CMS. If you are already using the web parts, you can simply re-import the package over the top of your installation to overwrite them, and they will work after that.

 

 

You might also be interested in

[X]

Be the first to know about my latest Kentico Tips & Tricks!

Do not show again